Voraussetzungen für den Bereich Plugin-Entwicklung

  • Voraussetzungen für den Bereich Plugin-Entwicklung


    Solltest du Interesse haben, dich als Entwickler zu bewerben, so solltest du bestenfalls folgende Voraussetzungen erfüllen:


    • Du solltest bestenfalls mindestens 14 Jahre alt sein (Ausnahmen bei besonderer Qualifikation & Reife möglich)
    • Erfahrung in der Programmierung mit Java und der Spigot-API für die Minecraft-Version 1.12.2
      • Einhalten der allgemeinen Java Conventions
      • Anwendung von MySQL sollte bekannt sein
      • Objektorientiert programmieren können (OOP)
      • Performanceorientiert programmieren können


    • Du solltest eigenständig arbeiten können und auch Termine und Fristen einhalten können, sowie dich nicht vor der Kommunikation mit anderen Teammitgliedern scheuen und auch etwas Humor mitbringen
    • Du solltest freitags um 19:00 Zeit haben, um an unserer wöchentlichen Teambesprechung teilnehmen zu können
    • Nutzung von GitLab ist Pflicht (dementsprechend muss die Nutzung eines Programmes wie "Sourcetree" auch bekannt sein!)
    • Bestenfalls sollten dir die Webseiten "uBugtrack" und "Slack" nicht unbekannt sein, da diese in der Organisation unseres Teams eine große Rolle spielen


    Solltest du die oben genannten Voraussetzungen erfüllen und auch bereit sein, Zeit in unser Projekt zu investieren, so würden wir uns über eine Bewerbung deinerseits sehr freuen und blicken einem Bewerbungsgespräch mit dir bereits jetzt zuversichtlich entgegen.

    Beste Grüße,

    FelesMemoriae!

    (Die Katze der Erinnerung)


    Freier Zivilist

    8 Mal editiert, zuletzt von MemoryMoment () aus folgendem Grund: GitLab ist nun Pflicht.